Пятница, 22.09.2017, 09:09


[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]

Страница 6 из 6«123456
Форум » Модификации Painkiller » Модификации и карты » SoulCatcher Weapon
SoulCatcher Weapon
metaljackСуббота, 12.08.2017, 22:49 | Сообщение # 76
Новичок
Сообщений: 12
Награды: 0
Репутация: 0
Статус: Offline
На уровне Ад вылетает при взятии мегапака. Black Edition 1.65 + powermad 3.63 + Soulcatcher.
 
STR_ParagorВоскресенье, 13.08.2017, 11:10 | Сообщение # 77
Technical Specialist
Сообщений: 351
Награды: 21
Репутация: 57
Статус: Offline
metaljack, Всему виной скорее всего неофициальный патч 1.65. Возможно в настройках уровнях, а именно в луа файле не указан тип патронов для Soulcatcher,a. Хотя точно ничего утверждать не могу, только предположил. Проходи уровень без подбора мегапаков. Оружие было написано только для официальной версии 1.64. Хотя почему то нормального описания на форуме нету куда и как устанавливать данный мод с оружием.
 
Painkiller-IvanВоскресенье, 13.08.2017, 14:31 | Сообщение # 78
Аластор
Сообщений: 313
Награды: 58
Репутация: 91
Статус: Online
STR_Paragor, может быть, всему виной комбинирование трёх составляющих, одно из которых перебивает работу другого, а именно повермад - соулкэтчер?
Цитата metaljack ()
На уровне Ад вылетает при взятии мегапака.

metaljack, в окне ошибки скрипта на какой файл мегапака жаловалась игра? Наименование файла.
 
dilettanteВоскресенье, 13.08.2017, 17:59 | Сообщение # 79
PK_GOD_and_KING
Сообщений: 117
Награды: 30
Репутация: 136
Статус: Offline
Цитата metaljack ()
На уровне Ад вылетает при взятии мегапака. Black Edition 1.65 + powermad 3.63 + Soulcatcher.

Исправил. Проявляется на 1.65, связано с одним из исправлений в CPlayer, где wybieram najsilniejsza bron (выбираем самое сильное оружие) было исправлено на 'первое доступное'. В резульате не инициализировалась переменная в Player.Ammo

Цитата STR_Paragor ()
Хотя почему то нормального описания на форуме нету куда и как устанавливать данный мод с оружием

Изначально была ссылка на страничку с указанием версии игры. Но всё это похерил хостинг для бедных и осталась только ссылка на сам файл. Мне даже в голову не пришло чиркнуть хоть строчку про 1.64, казалось сабо самой понятно.


Сообщение отредактировал dilettante - Воскресенье, 13.08.2017, 19:12
 
Painkiller-IvanВоскресенье, 13.08.2017, 19:20 | Сообщение # 80
Аластор
Сообщений: 313
Награды: 58
Репутация: 91
Статус: Online
Цитата dilettante ()
Исправил. Проявляется на 1.65, связано с одним из исправлений в CPlayer, где wybieram najsilniejsza bron (выбираем самое сильное оружие) было исправлено на 'первое доступное'. В резульате не инициализировалась переменная в Player.Ammo
Я доходил до этого по началу, но это исправляло ситуацию на не многих уровнях, потому как в луашках с уровнями нужно прописывать в набор включённых пушек SoulReaper и боеприпасы к нему. Твой мод изначально бы мог функционировать с патчем 1.65 (моим или Транзитом) и PM 3.63, если бы не скрипт на появление всего оружия на старте уровня (думаю, знаешь, о чём речь), над которым своё время уделял Транзит.


Сообщение отредактировал Painkiller-Ivan - Воскресенье, 13.08.2017, 19:24
 
dilettanteВоскресенье, 13.08.2017, 19:53 | Сообщение # 81
PK_GOD_and_KING
Сообщений: 117
Награды: 30
Репутация: 136
Статус: Offline
Инициализацию переменной под патроны делал 'на лету' по мере необходимости - подбор оружия, патронов, смена оружия, но пропустил в мегапаке и 'bestWeapon'. Так или иначе, это было плохое решение, нужна глобальная инициализация в каком-то одном месте.
 
Painkiller-IvanВоскресенье, 13.08.2017, 20:50 | Сообщение # 82
Аластор
Сообщений: 313
Награды: 58
Репутация: 91
Статус: Online
Как бы то ни было, у меня больше не вылетает, и повермад и душерезкой синхронно работают. Чуть-чуть подредактировал нумерацию модулей ракетницы и электродрайвера в паке, в менюшке они были перепутаны (то бишь текстовая ошибка).

В архиве есть версия SC + PM, так и SC без PM. Ставить на 1.65 версию игры. Ссылка

Исправил вылет входа в конфигурацию оружия (мой косяк). Перекачайте

Добавлено (13.08.2017, 20:50)
---------------------------------------------
Цитата STR_Paragor ()
Возможно в настройках уровнях, а именно в луа файле не указан тип патронов для Soulcatcher,a. Хотя точно ничего утверждать не могу, только предположил.
STR_Paragor, твои предположения верны, ибо на 1.64 скрипты набора оружия закомментированы в луа-файлах или отсутствовали, как в Аду, поэтому на официальной версии с мегпаками багов нет.


Сообщение отредактировал Painkiller-Ivan - Воскресенье, 13.08.2017, 20:51
 
metaljackПонедельник, 14.08.2017, 21:10 | Сообщение # 83
Новичок
Сообщений: 12
Награды: 0
Репутация: 0
Статус: Offline


Сообщение отредактировал STR_Paragor - Понедельник, 14.08.2017, 23:07
 
Painkiller-IvanПонедельник, 14.08.2017, 21:16 | Сообщение # 84
Аластор
Сообщений: 313
Награды: 58
Репутация: 91
Статус: Online


Сообщение отредактировал STR_Paragor - Понедельник, 14.08.2017, 23:09
 
Форум » Модификации Painkiller » Модификации и карты » SoulCatcher Weapon
Страница 6 из 6«123456
Поиск: